import re
regex = re.compile(r"^(?![^0\n]*0[^0\n]*(?:0[^0\n]*0)*[^0\n]*$)(?![^1\n]*1[^1\n]*(?:1[^1\n]*1)*[^1\n]*$)[10]*$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("100001\n"
"10001\n"
"1\n"
"11\n"
"00\n"
"1001\n"
"0101\n"
"011\n"
"101\n"
"1010")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")