using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<!--dle_image_begin:)((?:(?!\|-->).)*)(?=|-->)";
string input = @"<!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/1.png|--><img src=""some_url.com/uploads/posts/2012-12/1.png"" alt=""***"" title=""***"" /><!--dle_image_end--> bla bla bla bla <!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/2.png|--><img src=""some_url.com/uploads/posts/2012-12/2.png"" alt=""***"" title=""***"" /><!--dle_image_end--> bla bla bla <!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/3.png|--><img src=""some_url.com/uploads/posts/2012-12/3.png"" alt=""***"" title=""***"" /><!--dle_image_end-->";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}