# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=<!--dle_image_begin:)((?:(?!\|-->).)*)(?=|-->)"
test_str = "<!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/1.png|--><img src=\"some_url.com/uploads/posts/2012-12/1.png\" alt=\"***\" title=\"***\" /><!--dle_image_end--> bla bla bla bla <!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/2.png|--><img src=\"some_url.com/uploads/posts/2012-12/2.png\" alt=\"***\" title=\"***\" /><!--dle_image_end--> bla bla bla <!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/3.png|--><img src=\"some_url.com/uploads/posts/2012-12/3.png\" alt=\"***\" title=\"***\" /><!--dle_image_end-->"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.