import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<!--dle_image_begin:)((?:(?!\\|-->).)*)(?=|-->)";
final String string = "<!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/1.png|--><img src=\"some_url.com/uploads/posts/2012-12/1.png\" alt=\"***\" title=\"***\" /><!--dle_image_end--> bla bla bla bla <!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/2.png|--><img src=\"some_url.com/uploads/posts/2012-12/2.png\" alt=\"***\" title=\"***\" /><!--dle_image_end--> bla bla bla <!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/3.png|--><img src=\"some_url.com/uploads/posts/2012-12/3.png\" alt=\"***\" title=\"***\" /><!--dle_image_end-->";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}