const regex = /(?<=<!--dle_image_begin:)((?:(?!\|-->).)*)(?=|-->)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<!--dle_image_begin:)((?:(?!\\|-->).)*)(?=|-->)', 'g')
const str = `<!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/1.png|--><img src="some_url.com/uploads/posts/2012-12/1.png" alt="***" title="***" /><!--dle_image_end--> bla bla bla bla <!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/2.png|--><img src="some_url.com/uploads/posts/2012-12/2.png" alt="***" title="***" /><!--dle_image_end--> bla bla bla <!--dle_image_begin:http://some_url.com/uploads/posts/2012-12/3.png|--><img src="some_url.com/uploads/posts/2012-12/3.png" alt="***" title="***" /><!--dle_image_end-->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}