package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z]+)-((?:(?:0|[1-9](?:[0-9]+)?)\.){2}(?:0|[1-9](?:[0-9]+)?))$`)
var str = `package-0.0.1
package-0.1.1
package-1.0.1
package-0.10.1
package-0.01.1
package-01.0.1
package-0.0.01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}