const regex = /^([a-z]+)-((?:(?:0|[1-9](?:[0-9]+)?)\.){2}(?:0|[1-9](?:[0-9]+)?))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z]+)-((?:(?:0|[1-9](?:[0-9]+)?)\\.){2}(?:0|[1-9](?:[0-9]+)?))$', 'gm')
const str = `package-0.0.1
package-0.1.1
package-1.0.1
package-0.10.1
package-0.01.1
package-01.0.1
package-0.0.01`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}