import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z]+)-((?:(?:0|[1-9](?:[0-9]+)?)\\.){2}(?:0|[1-9](?:[0-9]+)?))$";
final String string = "package-0.0.1\n"
+ "package-0.1.1\n"
+ "package-1.0.1\n"
+ "package-0.10.1\n"
+ "package-0.01.1\n"
+ "package-01.0.1\n"
+ "package-0.0.01";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}