re = /^([a-z]+)-((?:(?:0|[1-9](?:[0-9]+)?)\.){2}(?:0|[1-9](?:[0-9]+)?))$/m
str = 'package-0.0.1
package-0.1.1
package-1.0.1
package-0.10.1
package-0.01.1
package-01.0.1
package-0.0.01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end