#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?: )*).+(?:\n\1((?: )+).*)(?:\n\1(?:(?: )+).*)*"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"i need help" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"for i in range(math.ceil(30/len(word)), 0, -1):" & @CRLF & _
" if len(tried) > 0:" & @CRLF & _
" print("so far you have tried ", ", ".join(tried))" & @CRLF & _
" print("lives", i)" & @CRLF & _
" while "_" in show:" & @CRLF & _
" print(show)" & @CRLF & _
" letter = input("type your guess : ")" & @CRLF & _
" if letter in tried:" & @CRLF & _
" print("You already tried that letter!")" & @CRLF & _
" continue" & @CRLF & _
" " & @CRLF & _
" tried.extend(letter)" & @CRLF & _
" if letter in word:" & @CRLF & _
" # loop" & @CRLF & _
" print("You got it right!")" & @CRLF & _
" for l in range(0, len(word)):" & @CRLF & _
" if word[l] == letter:" & @CRLF & _
" show = show[:l] + letter + show[l+1:]" & @CRLF & _
" " & @CRLF & _
" else:" & @CRLF & _
" print("You guess incorrectly :(")" & @CRLF & _
" break" & @CRLF & _
" if "_" not in show:" & @CRLF & _
" print("You won!")" & @CRLF & _
" exit()" & @CRLF & _
"print("You lost :(")" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"hi i want help on my skript" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"command /ownerrankgrant [<player>]:" & @CRLF & _
" permission: op" & @CRLF & _
" permission message: &cNOPE! NOT YET" & @CRLF & _
" trigger:" & @CRLF & _
" add arg-1 to {owner::*}" & @CRLF & _
" make console execute command "/op %arg-1%"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" trigger:" & @CRLF & _
" add arg-1 to {owner::*}" & @CRLF & _
" make console execute command "/op %arg-1%"" & @CRLF & _
"" & @CRLF & _
"on chat:" & @CRLF & _
" if {owner::*} contains the player:" & @CRLF & _
" set chat format to "&6&l[&e&lOWNER&6&l] &e%player% &f>> &b%message%"" & @CRLF & _
" else:" & @CRLF & _
" set chat format to "&8[&7DEFAULT&8] &7%player% &f>> &7%message%"" & @CRLF & _
"" & @CRLF & _
"command /ownerrankremove [<player>]:" & @CRLF & _
" permission: op" & @CRLF & _
" permission message: &cNOPE! NOT YET!" & @CRLF & _
" trigger:" & @CRLF & _
" remove arg-1 from {owner::*}" & @CRLF & _
" make console execute command "/deop %arg-1%"" & @CRLF & _
"```"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")