import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?: )*).+(?:\\n\\1((?: )+).*)(?:\\n\\1(?:(?: )+).*)*";
final String string = "\n\n\n\n\n\n\n\n"
+ "i need help\n\n\n\n\n\n"
+ "for i in range(math.ceil(30/len(word)), 0, -1):\n"
+ " if len(tried) > 0:\n"
+ " print(\"so far you have tried \", \", \".join(tried))\n"
+ " print(\"lives\", i)\n"
+ " while \"_\" in show:\n"
+ " print(show)\n"
+ " letter = input(\"type your guess : \")\n"
+ " if letter in tried:\n"
+ " print(\"You already tried that letter!\")\n"
+ " continue\n"
+ " \n"
+ " tried.extend(letter)\n"
+ " if letter in word:\n"
+ " # loop\n"
+ " print(\"You got it right!\")\n"
+ " for l in range(0, len(word)):\n"
+ " if word[l] == letter:\n"
+ " show = show[:l] + letter + show[l+1:]\n"
+ " \n"
+ " else:\n"
+ " print(\"You guess incorrectly :(\")\n"
+ " break\n"
+ " if \"_\" not in show:\n"
+ " print(\"You won!\")\n"
+ " exit()\n"
+ "print(\"You lost :(\")\n\n\n\n\n\n\n\n"
+ "hi i want help on my skript\n\n\n\n"
+ "```\n"
+ "command /ownerrankgrant [<player>]:\n"
+ " permission: op\n"
+ " permission message: &cNOPE! NOT YET\n"
+ " trigger:\n"
+ " add arg-1 to {owner::*}\n"
+ " make console execute command \"/op %arg-1%\"\n\n\n"
+ " trigger:\n"
+ " add arg-1 to {owner::*}\n"
+ " make console execute command \"/op %arg-1%\"\n\n"
+ "on chat:\n"
+ " if {owner::*} contains the player:\n"
+ " set chat format to \"&6&l[&e&lOWNER&6&l] &e%player% &f>> &b%message%\"\n"
+ " else:\n"
+ " set chat format to \"&8[&7DEFAULT&8] &7%player% &f>> &7%message%\"\n\n"
+ "command /ownerrankremove [<player>]:\n"
+ " permission: op\n"
+ " permission message: &cNOPE! NOT YET!\n"
+ " trigger:\n"
+ " remove arg-1 from {owner::*}\n"
+ " make console execute command \"/deop %arg-1%\"\n"
+ "```";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}