const regex = /!\[(.*?)\]\((https?:\/\/\S+\.\w+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('!\\[(.*?)\\]\\((https?:\\\/\\\/\\S+\\.\\w+)\\)', 'gm')
const str = `.png)
`;
const subst = `"<img alt='$1' src='$2' />"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);