re = /!\[(.*?)\]\((https?:\/\/\S+\.\w+)\)/m
str = '.png)
'
subst = '"<img alt=\'$1\' src=\'$2\' />"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result