// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)!\[(.*?)\]\((https?:\/\/\S+\.\w+)\)").unwrap();
let string = ".png)
";
let substitution = "\"<img alt='$1' src='$2' />\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}