use strict;
my $str = '.png)
';
my $regex = qr/!\[(.*?)\]\((https?:\/\/\S+\.\w+)\)/mp;
my $subst = '"<img alt=\'$1\' src=\'$2\' />"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";