#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9]{2}\.[0-9]{2}\.[0-9]{4}\s[0-9]{2}:[0-9]{2}:[0-9]{2}).*?\n-{1,}\sFG\s+?4"
Local $sString = "19.04.2016 01:59:18 ASDF" & @CRLF & _
"---- FG 3" & @CRLF & _
" --------------- ASDF" & @CRLF & _
"19.04.2016 01:59:21 ASDF" & @CRLF & _
"---- FG 4" & @CRLF & _
" --------------- ASDF" & @CRLF & _
"19.04.2016 01:59:22 ASDF" & @CRLF & _
"---- FG 4" & @CRLF & _
" --------------- ASDF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")