package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{2}\.[0-9]{2}\.[0-9]{4}\s[0-9]{2}:[0-9]{2}:[0-9]{2}).*?\n-{1,}\sFG\s+?4`)
var str = `19.04.2016 01:59:18 ASDF
---- FG 3
--------------- ASDF
19.04.2016 01:59:21 ASDF
---- FG 4
--------------- ASDF
19.04.2016 01:59:22 ASDF
---- FG 4
--------------- ASDF`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}