# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]{2}\.[0-9]{2}\.[0-9]{4}\s[0-9]{2}:[0-9]{2}:[0-9]{2}).*?\n-{1,}\sFG\s+?4"
test_str = ("19.04.2016 01:59:18 ASDF\n"
"---- FG 3\n"
" --------------- ASDF\n"
"19.04.2016 01:59:21 ASDF\n"
"---- FG 4\n"
" --------------- ASDF\n"
"19.04.2016 01:59:22 ASDF\n"
"---- FG 4\n"
" --------------- ASDF")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.