re = /([0-9]{2}\.[0-9]{2}\.[0-9]{4}\s[0-9]{2}:[0-9]{2}:[0-9]{2}).*?\n-{1,}\sFG\s+?4/m
str = '19.04.2016 01:59:18 ASDF
---- FG 3
 --------------- ASDF
19.04.2016 01:59:21 ASDF
---- FG 4
 --------------- ASDF
19.04.2016 01:59:22 ASDF
---- FG 4
 --------------- ASDF'
# Print the match result
str.match(re) do |match|
    puts match.to_s
end