const regex = /dashboard_|composition_/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('dashboard_|composition_', '')
const str = `page_dashboard
dashboard_trainings
composition_trainings
ltr
fr
js
yjctmvqc
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}