import Foundation
let pattern = #"dashboard_|composition_"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
page_dashboard
dashboard_trainings
composition_trainings
ltr
fr
js
yjctmvqc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}