$re = '/dashboard_|composition_/';
$str = 'page_dashboard
dashboard_trainings
composition_trainings
ltr
fr
js
yjctmvqc
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);