using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.{7}$|(^\d{1,7}?$\.?\r?\n?)";
string input = @"1
12
123
1234
12345
123456
1234567
123456!
123456'
123456^
123456+
123456%
123456&
123456/
123456(
123456)
123456=
123456_
123456-
+123456
!autoit
autoit+
12345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}