import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.{7}$|(^\\d{1,7}?$\\.?\\r?\\n?)";
final String string = "1\n"
+ "12\n"
+ "123\n"
+ "1234\n"
+ "12345\n"
+ "123456\n"
+ "1234567\n"
+ "123456!\n"
+ "123456'\n"
+ "123456^\n"
+ "123456+\n"
+ "123456%\n"
+ "123456&\n"
+ "123456/\n"
+ "123456(\n"
+ "123456)\n"
+ "123456=\n"
+ "123456_\n"
+ "123456-\n"
+ "+123456\n"
+ "!autoit\n"
+ "autoit+\n"
+ "12345678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}