// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.{7}$|(^\d{1,7}?$\.?\r?\n?)").unwrap();
let string = "1
12
123
1234
12345
123456
1234567
123456!
123456'
123456^
123456+
123456%
123456&
123456/
123456(
123456)
123456=
123456_
123456-
+123456
!autoit
autoit+
12345678";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}