$re = '/{{(?>[^}{]+|(?0))*}} ?/';
$str = 'Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there.
Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there {{my }} friend.
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;