re = /{{(?>[^}{]+|(?0))*}} ?/
str = 'Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there.
Hello {{world of the {{ crazy}} {{need {{ be}}}} sea }} there {{my }} friend.
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result