use strict;
my $str = 'http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2
http://regex101.com/r/fW0_Z2';
my $regex = qr/^https?://regex101\.com/r/([^\W_]{6})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}