re = /^https?:\/\/regex101\.com\/r\/([^\W_]{6})$/m
str = 'http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2
http://regex101.com/r/fW0_Z2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end