$re = '/^https?://regex101\.com/r/([^\W_]{6})$/m';
$str = 'http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2
http://regex101.com/r/fW0_Z2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);