#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)test"
Local $sString = "mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm" & @CRLF & _
"mmmmm <a href="ttt">test</a> mmmm mmmmm test test mm mmmmmmm" & @CRLF & _
"mmmmm <a href="ttt"> test </a> mmmm mmmmm test test mm mmmmmmm" & @CRLF & _
"mmmmm <a href="ttt">mmm test</a> mmmm mmmmm test test mmmmmmmm" & @CRLF & _
"mmmmm <a href="ttt">test mmm </a> mmmm mmmmm test test mmmmmmm" & @CRLF & _
"mmmmm <a href="ttt" > mmm test mmm </a> mmmm mm test test mmmm" & @CRLF & _
"mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")