use strict;
my $str = 'mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm
mmmmm <a href="ttt">test</a> mmmm mmmmm test test mm mmmmmmm
mmmmm <a href="ttt"> test </a> mmmm mmmmm test test mm mmmmmmm
mmmmm <a href="ttt">mmm test</a> mmmm mmmmm test test mmmmmmmm
mmmmm <a href="ttt">test mmm </a> mmmm mmmmm test test mmmmmmm
mmmmm <a href="ttt" > mmm test mmm </a> mmmm mm test test mmmm
mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm';
my $regex = qr/test/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}