// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)test").unwrap();
let string = "mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm
mmmmm <a href=\"ttt\">test</a> mmmm mmmmm test test mm mmmmmmm
mmmmm <a href=\"ttt\"> test </a> mmmm mmmmm test test mm mmmmmmm
mmmmm <a href=\"ttt\">mmm test</a> mmmm mmmmm test test mmmmmmmm
mmmmm <a href=\"ttt\">test mmm </a> mmmm mmmmm test test mmmmmmm
mmmmm <a href=\"ttt\" > mmm test mmm </a> mmmm mm test test mmmm
mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}