import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "test";
final String string = "mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm\n"
+ "mmmmm <a href=\"ttt\">test</a> mmmm mmmmm test test mm mmmmmmm\n"
+ "mmmmm <a href=\"ttt\"> test </a> mmmm mmmmm test test mm mmmmmmm\n"
+ "mmmmm <a href=\"ttt\">mmm test</a> mmmm mmmmm test test mmmmmmmm\n"
+ "mmmmm <a href=\"ttt\">test mmm </a> mmmm mmmmm test test mmmmmmm\n"
+ "mmmmm <a href=\"ttt\" > mmm test mmm </a> mmmm mm test test mmmm\n"
+ "mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}