$re = '/([\d\s\.,:\/]+)/';
$str = '335.31, 312.52
Dave1.532
Path: "./1243/453 /48.1"
543, 546
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);