// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\d\s\.,:\/]+)").unwrap();
let string = "335.31, 312.52
Dave1.532
Path: \"./1243/453 /48.1\"
543, 546
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}