#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^(\/]+)(?:\((.*?)\))?\/([^?]+)\?select=(.*)$"
Local $sString = "Table_name(1)/field?select=Name" & @CRLF & _
"Table_name/field?select=Name" & @CRLF & _
"bla-bla-bla(123)/zsdfgdsg?select=Name2" & @CRLF & _
"bla-bla-bla(897646)/rytutuityi?select=Name3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")