// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^(\/]+)(?:\((.*?)\))?\/([^?]+)\?select=(.*)$").unwrap();
let string = "Table_name(1)/field?select=Name
Table_name/field?select=Name
bla-bla-bla(123)/zsdfgdsg?select=Name2
bla-bla-bla(897646)/rytutuityi?select=Name3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}