re = /^([^(\/]+)(?:\((.*?)\))?\/([^?]+)\?select=(.*)$/m
str = 'Table_name(1)/field?select=Name
Table_name/field?select=Name
bla-bla-bla(123)/zsdfgdsg?select=Name2
bla-bla-bla(897646)/rytutuityi?select=Name3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end