$re = '/^([^(\/]+)(?:\((.*?)\))?\/([^?]+)\?select=(.*)$/m';
$str = 'Table_name(1)/field?select=Name
Table_name/field?select=Name
bla-bla-bla(123)/zsdfgdsg?select=Name2
bla-bla-bla(897646)/rytutuityi?select=Name3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);