#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\.0*[1-9]\d*$|^0(\.0*[1-9]\d*)$|^[1-9]\d*?(\.\d+)?$"
Local $sString = "0" & @CRLF & _
"-0" & @CRLF & _
"0.0" & @CRLF & _
"0000" & @CRLF & _
".0" & @CRLF & _
".0000" & @CRLF & _
"000." & @CRLF & _
"0.0" & @CRLF & _
"0.000000" & @CRLF & _
"0000.0" & @CRLF & _
"0000.1" & @CRLF & _
"========================" & @CRLF & _
".1" & @CRLF & _
".0001" & @CRLF & _
".010" & @CRLF & _
"0.0001" & @CRLF & _
"0.1111" & @CRLF & _
"0.1100" & @CRLF & _
"0.1" & @CRLF & _
"1.0" & @CRLF & _
"101" & @CRLF & _
"101.0" & @CRLF & _
"101.000" & @CRLF & _
"101.0001" & @CRLF & _
"101.0001000" & @CRLF & _
"1111.00000" & @CRLF & _
"1000" & @CRLF & _
"========================" & @CRLF & _
"0111" & @CRLF & _
"010.1" & @CRLF & _
"0110" & @CRLF & _
"000001" & @CRLF & _
"000100" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")