// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\.0*[1-9]\d*$|^0(\.0*[1-9]\d*)$|^[1-9]\d*?(\.\d+)?$").unwrap();
let string = "0
-0
0.0
0000
.0
.0000
000.
0.0
0.000000
0000.0
0000.1
========================
.1
.0001
.010
0.0001
0.1111
0.1100
0.1
1.0
101
101.0
101.000
101.0001
101.0001000
1111.00000
1000
========================
0111
010.1
0110
000001
000100
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}