using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\.0*[1-9]\d*$|^0(\.0*[1-9]\d*)$|^[1-9]\d*?(\.\d+)?$";
string input = @"0
-0
0.0
0000
.0
.0000
000.
0.0
0.000000
0000.0
0000.1
========================
.1
.0001
.010
0.0001
0.1111
0.1100
0.1
1.0
101
101.0
101.000
101.0001
101.0001000
1111.00000
1000
========================
0111
010.1
0110
000001
000100
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}