import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\.0*[1-9]\\d*$|^0(\\.0*[1-9]\\d*)$|^[1-9]\\d*?(\\.\\d+)?$";
final String string = "0\n"
+ "-0\n"
+ "0.0\n"
+ "0000\n"
+ ".0\n"
+ ".0000\n"
+ "000.\n"
+ "0.0\n"
+ "0.000000\n"
+ "0000.0\n"
+ "0000.1\n"
+ "========================\n"
+ ".1\n"
+ ".0001\n"
+ ".010\n"
+ "0.0001\n"
+ "0.1111\n"
+ "0.1100\n"
+ "0.1\n"
+ "1.0\n"
+ "101\n"
+ "101.0\n"
+ "101.000\n"
+ "101.0001\n"
+ "101.0001000\n"
+ "1111.00000\n"
+ "1000\n"
+ "========================\n"
+ "0111\n"
+ "010.1\n"
+ "0110\n"
+ "000001\n"
+ "000100\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}