use strict;
my $str = 'src="./seg3125_p2.github.io/images/img-1.jpg"
src=\'./images/img-1.jpg\'
src= "./seg3125_p2.github.io/images/img-1.jpg"
src= \'./images/img-1.jpg\'
background-image: url("https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg");
background-image: url(\'https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg\');
background-image:url("https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg");
background-image:url(\'https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg\');
<video src={"./seg3125_p2.github.io/videos/video-1.mp4"}/>
<video src={\'./seg3125_p2.github.io/videos/video-1.mp4\'}/>
<video
src={"./seg3125_p2.github.io/videos/video-1.mp4"}
autoPlay="autoPlay"
loop="loop"
muted="muted"
playsInline="playsInline"
/>';
my $regex = qr/^.*\b(?:src=|background\-image:).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}