import Foundation
let pattern = #"^.*\b(?:src=|background\-image:).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
src="./seg3125_p2.github.io/images/img-1.jpg"
src='./images/img-1.jpg'
src= "./seg3125_p2.github.io/images/img-1.jpg"
src= './images/img-1.jpg'
background-image: url("https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg");
background-image: url('https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg');
background-image:url("https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg");
background-image:url('https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg');
<video src={"./seg3125_p2.github.io/videos/video-1.mp4"}/>
<video src={'./seg3125_p2.github.io/videos/video-1.mp4'}/>
<video
src={"./seg3125_p2.github.io/videos/video-1.mp4"}
autoPlay="autoPlay"
loop="loop"
muted="muted"
playsInline="playsInline"
/>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)