re = /^.*\b(?:src=|background\-image:).*$/m
str = 'src="./seg3125_p2.github.io/images/img-1.jpg"
src=\'./images/img-1.jpg\'
src= "./seg3125_p2.github.io/images/img-1.jpg"
src= \'./images/img-1.jpg\'
background-image: url("https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg");
background-image: url(\'https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg\');
background-image:url("https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg");
background-image:url(\'https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg\');
<video src={"./seg3125_p2.github.io/videos/video-1.mp4"}/>
<video src={\'./seg3125_p2.github.io/videos/video-1.mp4\'}/>
<video
src={"./seg3125_p2.github.io/videos/video-1.mp4"}
autoPlay="autoPlay"
loop="loop"
muted="muted"
playsInline="playsInline"
/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end