#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)0?(?P<month>10|11|12|1|2|3|4|5|6|7|8|9)[—](?P<day>[1-2][0-9]|3[0-1]|[0]?[1-9])[—](?P<year>(19|20)\d{2})[ ](?P<desc>.*?)[ ](?P<amount>[-]?[S]?\d*\.\d+)"
Local $sString = "11—04—2022 ACH Deposit Square Inc 221104P2 126.42" & @CRLF & _
"11—07—2022 ACH Deposit Square Inc 221107P2 184.86" & @CRLF & _
"11—07—2022 ACH Deposit Square Inc 221107P2 225.67" & @CRLF & _
"11—09—2022 ACH Deposit Square Inc 221109P2 277.19" & @CRLF & _
"11—10—2022 ACH Deposit Square Inc 221110P2 306.31" & @CRLF & _
"11—14—2022 ACH Deposit Square Inc 221114P2 19.38" & @CRLF & _
"11—14—2022 ACH Deposit Square Inc 221111P2 126.42" & @CRLF & _
"11—14—2022 ACH Deposit Square Inc 221114P2 213.98" & @CRLF & _
"11—16—2022 ACH Deposit Square Inc 221116P2 175.02" & @CRLF & _
"11—17—2022 ACH Deposit Square Inc 221117P2 157.49" & @CRLF & _
"11—18—2022 ACH Deposit Square Inc 221118P2 308.4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")