use strict;
my $str = '11—04—2022 ACH Deposit Square Inc 221104P2 126.42
11—07—2022 ACH Deposit Square Inc 221107P2 184.86
11—07—2022 ACH Deposit Square Inc 221107P2 225.67
11—09—2022 ACH Deposit Square Inc 221109P2 277.19
11—10—2022 ACH Deposit Square Inc 221110P2 306.31
11—14—2022 ACH Deposit Square Inc 221114P2 19.38
11—14—2022 ACH Deposit Square Inc 221111P2 126.42
11—14—2022 ACH Deposit Square Inc 221114P2 213.98
11—16—2022 ACH Deposit Square Inc 221116P2 175.02
11—17—2022 ACH Deposit Square Inc 221117P2 157.49
11—18—2022 ACH Deposit Square Inc 221118P2 308.4';
my $regex = qr/0?(?P<month>10|11|12|1|2|3|4|5|6|7|8|9)[—](?P<day>[1-2][0-9]|3[0-1]|[0]?[1-9])[—](?P<year>(19|20)\d{2})[ ](?P<desc>.*?)[ ](?P<amount>[-]?[S]?\d*\.\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}