import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "0?(?P<month>10|11|12|1|2|3|4|5|6|7|8|9)[—](?P<day>[1-2][0-9]|3[0-1]|[0]?[1-9])[—](?P<year>(19|20)\\d{2})[ ](?P<desc>.*?)[ ](?P<amount>[-]?[S]?\\d*\\.\\d+)";
final String string = "11—04—2022 ACH Deposit Square Inc 221104P2 126.42\n"
+ "11—07—2022 ACH Deposit Square Inc 221107P2 184.86\n"
+ "11—07—2022 ACH Deposit Square Inc 221107P2 225.67\n"
+ "11—09—2022 ACH Deposit Square Inc 221109P2 277.19\n"
+ "11—10—2022 ACH Deposit Square Inc 221110P2 306.31\n"
+ "11—14—2022 ACH Deposit Square Inc 221114P2 19.38\n"
+ "11—14—2022 ACH Deposit Square Inc 221111P2 126.42\n"
+ "11—14—2022 ACH Deposit Square Inc 221114P2 213.98\n"
+ "11—16—2022 ACH Deposit Square Inc 221116P2 175.02\n"
+ "11—17—2022 ACH Deposit Square Inc 221117P2 157.49\n"
+ "11—18—2022 ACH Deposit Square Inc 221118P2 308.4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}